Меню

Home assistant samba share не работает

Делаем сетевые папки на сервере HassOS Home Assistant с помощью аддона samba share

Октябрь 23, 2020

Сервер Home Assistant у меня развернут на raspberry pi: http://ali.pub/53kjyp

В данной статье расскажу как легко и просто сделать сетевую папку на сервере home assistant.

Для чего это нужно? А нужно это для того чтоб устанавливать в Home Assistant сторонние аддоны, например такие как HACS.

Сетевую папку будем делать с помощью аддона Samba share. Данный аддон поднимает samba в ОС под управлением Home Assistant.

В Home Assistant заходим Supervisor-> Add-on store-> Samba share и устанавливаем данный плагин.

Во время установки у нас спросит произвести конфигурацию. Соглашаемся и откроется окно:

По сути здесь можно ничего не менять за исключением граф username и password. Заданные имя и пароль будут запрашиваться при подключении к сетевому диску.

Важно: пароль не должен состоять из цифр и в таких ” кавычках.

После этого нажимаем кнопку save и во вкладке info нажимаем кнопку start для запуска Samba.

После запуска аддона Samba share мы сможем зайти в сетевые папки. Для этого в окне любой папки ( где пишется путь к папке) вобьем \\адрес homeassistant. В моем случае это будет \\10.155.223.79 и выглядеть это будет так:

И нажимаем Enter. Далее у нас запросит логин и пароль. Вписываем учетные данные которые прописывали в конфиге.

После этого мы войдем в наши папки:

На этом настройка самбы закончена. Теперь мы сможем устанавливать в home assistant сторонние аддоны и плагины.

Источник

Samba add-on doesn’t start #774

Comments

ivelin commented Oct 11, 2019

Just installed Samba add-on on a brand new clean Hass.io image on RPI4. Waited 15 minutes after Start. Still no logs. No obvious indication what’s going on. Maybe I’m missing something obvious. Screenshots attached for reference.



The text was updated successfully, but these errors were encountered:

frenck commented Oct 12, 2019

Could you please supply some logs?
If there are logs from the add-on tab, that would be nice.
Else, there are always logs visible in Hass.io panel -> System tab -> Logs

ivelin commented Oct 12, 2019

OK, I got it start. See longs.

It wasn’t obvious from the add-on intro screen or docs that password cannot be left as null. Similar to the other services, the initial UX is confusing. Maybe we can think about a mandatory initial screen for any add-on that makes sure the user understands and enters the minimum required information.

What also makes things confusing is that the Hass.io official documentation promises the user that they won’t have to deal with authentication for each add-on, because that’s part of the contract between the add-on developer and Hass.io. So having to bump into basic authentication , login and SSL for an add-on that’s running within Hass.io’s already SSL and credentials secured local UI is counter intuitive.

I will ping @frenck on Discord to see how we can turn this discussion into action.

Читайте также:  Как настроить пончиковый аппарат гольфстрим

Feel free to close this issue.

frenck commented Oct 12, 2019 — with Octobox

I guess the installation steps for this addon could use an additional step, let’s leave this issue open to achieve that

dtx360 commented Oct 12, 2019

A related follow-up on the original issue (add-on not starting):

When I tried to access my samba share today the add-on had failed to start.
Checking the add-on log and it says:
/run.sh: line 21: bashio::log.warn: command not found

The Hassio log just says:
19-10-12 18:28:32 INFO (SyncWorker_6) [hassio.docker.addon] Start Docker add-on homeassistant/armv7-addon-samba with version 8.2

Tried to re-install add-on, update HA to 0.100, re-install add-on again, still no-go.

robmikulec commented Oct 13, 2019

A related follow-up on the original issue (add-on not starting):

When I tried to access my samba share today the add-on had failed to start.
Checking the add-on log and it says:
/run.sh: line 21: bashio::log.warn: command not found

The Hassio log just says:
19-10-12 18:28:32 INFO (SyncWorker_6) [hassio.docker.addon] Start Docker add-on homeassistant/armv7-addon-samba with version 8.2

Tried to re-install add-on, update HA to 0.100, re-install add-on again, still no-go.

I am having the exact same issue. Any help would be greatly appreciated,

Источник

Samba share connection failed after update #1252

Comments

Amathagma commented Apr 26, 2020

Hi,
I can’t make samba share to work after update. I think everything was fine in 8.3.0 version (not really sure if that was the version I had before the update) but after update to 9.2.0 can’t anymore login to hassio.
Tried to restart, uninstall and reinstall, nothing worked. I can see my hassio exposed to network but can’t login. Just connection failed, that’s all.
Log file is big enough, tell me if you need any info from this. Last log file says:
Could not find child 289 — ignoring

The text was updated successfully, but these errors were encountered:

frenck commented Apr 26, 2020

please provide the full log. Thanks 👍

Amathagma commented Apr 26, 2020

Ok, here it is (I hope I didn’t hide too much ip’s):
`Log
[s6-init] making user provided files available at /var/run/s6/etc. exited 0.
[s6-init] ensuring user provided files have correct perms. exited 0.
[fix-attrs.d] applying ownership & permissions fixes.
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts.
[cont-init.d] samba.sh: executing.
[18:41:06] INFO: Hostname: hassio
No builtin backend found, trying to load plugin
tdbsam_open: Converting version 0.0 database to version 4.0.
tdbsam_convert_backup: updated /var/lib/samba/private/passdb.tdb file.
account_policy_get: tdb_fetch_uint32_t failed for type 1 (min password length), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 2 (password history), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 3 (user must logon to change password), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 4 (maximum password age), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 5 (minimum password age), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 6 (lockout duration), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 7 (reset count minutes), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 8 (bad lockout attempt), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 9 (disconnect time), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 10 (refuse machine password change), returning 0
Added user my_name.
[cont-init.d] samba.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
nmbd version 4.11.5 started.
Copyright Andrew Tridgell and the Samba Team 1992-2019
Registered MSG_REQ_POOL_USAGE
Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
added interface enp0s3 ip=xxxx:xxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx bcast= netmask=ffff:ffff:ffff:ffff::
added interface docker0 ip=172.xx.x.x bcast=172.xx.xxx.xxx netmask=255.xxx.x.x
added interface hassio ip=172.xx.xx.x bcast=172.xx.xx.xxx netmask=255.255.254.0
added interface enp0s3 ip=192.168.x.xxx bcast=192.168.1.255 netmask=255.255.255.0
making subnet name:192.168.x.xxx Broadcast address:192.168.1.255 Subnet mask:255.255.255.0
making subnet name:172.xx.xx.x Broadcast address:172.xx.xx.xxx Subnet mask:255.255.254.0
making subnet name:172.xx.x.x Broadcast address:172.xx.xxx.xxx Subnet mask:255.255.0.0
create_subnets: ignoring non IPv4 interface.
making subnet name:UNICAST_SUBNET Broadcast address:0.0.0.0 Subnet mask:0.0.0.0
making subnet name:REMOTE_BROADCAST_SUBNET Broadcast address:0.0.0.0 Subnet mask:0.0.0.0
daemon_ready: daemon ‘nmbd’ finished starting up and ready to serve connections
smbd version 4.11.5 started.
Copyright Andrew Tridgell and the Samba Team 1992-2019
Registered MSG_REQ_POOL_USAGE
Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
Processing section «[config]»
Processing section «[addons]»
Processing section «[ssl]»
[services.d] done.
Processing section «[share]»
Processing section «[backup]»
added interface enp0s3 ip=xxxx:xxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx bcast= netmask=ffff:ffff:ffff:ffff::
added interface docker0 ip=172.xx.x.x bcast=172.xx.xxx.xxx netmask=255.255.0.0
added interface hassio ip=172.xx.xx.x bcast=172.xx.xx.xxx netmask=255.255.254.0
added interface enp0s3 ip=192.xxx.x.xxx bcast=192.168.1.255 netmask=255.255.255.0
INFO: Profiling support unavailable in this build.
No builtin backend found, trying to load plugin
daemon_ready: daemon ‘smbd’ finished starting up and ready to serve connections
waiting for connections
check_for_master_browser_fail: Forcing election on workgroup WORKGROUP subnet 172.xx.x.x
check_for_master_browser_fail: Forcing election on workgroup WORKGROUP subnet 172.xx.xx.x
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.xx.x.x
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.xx.xx.x
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.xx.x.x
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.xx.xx.x
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.xx.x.x
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.xx.xx.x
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.xx.x.x
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.xx.xx.x
send_election_dgram: Sending election packet for workgroup WORKGROUP on subnet 172.xx.x.x
run_elections: >>> Won election for workgroup WORKGROUP on subnet 172.xx.x.x >> Won election for workgroup WORKGROUP on subnet 172.xx.xx.x

Читайте также:  Как настроить профиль шикимори

Samba name server HASSIO is now a local master browser for workgroup WORKGROUP on subnet 172.xx.x.x

Samba name server HASSIO is now a local master browser for workgroup WORKGROUP on subnet 172.xx.xx.x

Could not find child 289 — ignoring
Could not find child 292 — ignoring`

jackob007 commented Apr 29, 2020

I have the same problem.
Today’s fresh installation of hassio on Proxmox.
Cannot migrate from RPi via snapshots 🙁

Thanks for your help!

goprojojo commented May 5, 2020

Having the same issue. Any solution on this issue yet?

jdbrookes commented May 7, 2020

I had this same issue after updating core to 109.3 this week.

Solution for me was to reset the Samba Share config entirely, ensure the IP range in allowed_hosts was correct, and then reconfigure my samba share password (including quotes).

tre4b commented May 21, 2020

Just getting back into HA after a break and, well did all the updates and found I could no longer access Samba. Heck I can no longer even figure out where the config is as the config section that was there no longer seems to exist and I can find no other way to locate the config.

Do I now need to access on the linux level to do the config or something?

jdbrookes commented May 21, 2020

Just getting back into HA after a break and, well did all the updates and found I could no longer access Samba. Heck I can no longer even figure out where the config is as the config section that was there no longer seems to exist and I can find no other way to locate the config.

Do I now need to access on the linux level to do the config or something?

Читайте также:  Новое стекло не работает

They’ve broken AddOns into tabs, so you should see tabs for Configuration, Logs etc along the top when you open the AddOn in the Supervisor page.

tdejneka commented May 22, 2020

I am experiencing a nearly identical problem with the Samba Add-On. I have it running on an RPI3 and I can connect to it using MacOS and Windows but not with Ubuntu (neither 18.04 or 20.04).

The Home Assistant server appears in the Networks list. Login attempts are denied (message is «Permission denied»). The same credentials work with MacOS and Windows.

In addition, if you attempt to browse the Home Assistant’s server’s available samba shares (by entering smb://servername ), it reports it is unable to acquire the list.

Unable to access location.
Failed to receive share list from server. Connection timed out.

Curiously, the Samba Add-On’s log does not report anything concerning the failed connection attempt. It reports successful connections but shows nothing when I repeatedly try, but fail, to connect from the Ubuntu machine.

Источник

Home Assistant. Урок 9 ADD-ON. Часть 1 — Samba

Все новости мира умных домов — t.me/SprutAI_News или Instagram
Остались вопросы? Мы в Telegram — @SprutAI

Спасибо всё как всегда доходчиво. Хотел узнать только есть способ установки Samba на venv.

Приветствую всех! Столкнулся с такой проблемой, устанавливаю любой аддон, Хасио перезагружается сам без команды на перезагрузку. После перезагрузки вижу что аддон установлен, но не запускается пишет ошибку

404 Client Error for http+docker://localhost/v1.41/containers/create?name=addon_7ad98f9c_zigbee2mqtt: Not Found («No such image: zigbee2mqtt/zigbee2mqtt-armv7:1.18.1-1»)

Это происходит с любым аддоном. Переустанавливал docker, Portainer несколько раз не помогает, уже руки отпускаются (переустановил расбиан и хасио наверное 15 раз, уже как 8 разных бэкапов, 3 флешки с готовыми прошивками и хасио).

Источник

Adblock
detector