Меню

Как настроить cisco 2911

Мой МеморизИТ

Начинаем курс статей под кодовым названием Cisco для новичков

Собственно сабжект говорит о том что я постараюсь описать в данной статье…

Имеем Cisco 2911… поехали

начну с того, что на 18XX 28XX и почих маршрутизаторах 8 серии подключение и первоначальная настройка оборудования осуществляется через консольный порт с разъемом RJ-45, обычно, кабель для настройки идет в комплекте, представляет из себя RJ-45 на RS-232 голубого цвета. Оборудование 19XX 29XX серий помимо консольного порта RJ 45 имеет консольный порт MiniUSB (Что значительно удобнее при настройке оборудования имея под рукой ноутбук с отсутствующим COM портом). Для настройки оборудования через MiniUSB нам понадобится драйвер эмуляции
Далее в Device Manager появится Cisco Serial где можно настроить номер порта.

Установка соединения осуществляется со стандартными значениями – 9600 бод/8 бит данных/1 стоп бит/без проверки четности и контроля прохождения. В Windows – системах вы можете использовать putty, в Linux cu или minicom. В дальнейшем, когда маршрутизатору будет присвоен IP-адрес для настроек будем использовать ssh, но первый раз без консольного подключения не обойтись.

Открываем Putty, выбираем тип подключения Serial порт COM7 ( У меня он COM7) нажимаем 2 раза [Enter] и видим меред собой командную строку с приглашением роутера

Router>
Переходим в превелегированный режим командой enable
Router>enable
Router#
удаляем имеющуюся конфигурацию, находящуюся во флэш-памяти, и перезагружаем маршрутизатор:
Router#erase startup-config
Router#reload
Ждем пока роутер перезагрузится, наблюдая за процессом загрузки в окне консоли, после чего снова переходим в превилигированный режим
Router>enable

Переходим в конфигурационный режим и даем команду hostname:
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Gw0
Gw0(config)#
Включим режим хранения паролей в файле конфигурации устройства в зашифрованном виде:
Gw0(config)#service password-encryption
Отключим управление маршрутизатором через http и https и CDP
Gw0(config)#no ip http server
Gw0(config)#no ip http secure-server
Gw0(config)#no cdp run
Зададим пароли на подключения через консольный порт
Gw0(config)#line con 0
Gw0(config-line)#password пароль
Gw0(config-line)#login
Gw0(config-line)#exit
И Telnet
Gw0(config)#line vty ? О, сколько он там сказал доступно? 0-1441 значит line vty 0 1441 ))
Gw0(config-line)#password пароль
Gw0(config-line)#login
Gw0(config-line)#exit
Зададим пароль на Enable режим
Gw0(config) enable secret пароль_enable_режима

Перейдем к настройке интерфейса внутренней сети. Если маршрутизатор имеет гигабитные порты то названия портов можно сократить как Gi 0/0 (Gigabit ethernet) , если 100 Мбитные то скорее всего это будут Fa (fast ethernet)
В принципе, если вы сомневаетесь в команде, нажмите TAB — в командной строке команда дописалась? значит норма, не помните что вводить? введите знак вопроса… IOS выдаст вам все доступные команды в данном контексте.
Gw0(config) #interface Gi 0/0
Gw0(config-if)#ip address 192.168.0.1 255.255.255.0
Gw0(config-if)#description LAN
Gw0(config-if)#no shutdown
Gw0(config-if)#exit
Задаем dns-сервера

Gw0(config)# ip name-server 192.168.0.2

Все, маршрутизатор доступен телнетом по 192.168.0.1
Записываем конфигурацию в память командой
Gw0# copy running-config startup config или командой wr

Читайте также:  Симс 3 печь для пиццы не работает

В следующей статье,собственно, мы отключим доступ на маршрутизатор через telnet (Ибо не секюрно ) и настроим доступ к нему используя SSH.

Источник

Как настроить cisco 2911

Всем привет сегодня мы с вами поговорим про такую вещь как статическая маршрутизация в оборудовании Cisco. Эта статья продолжение поста Как настроить маршрутизатор cisco / Организация сети для небольшого офиса. Там мы настроили локальную сеть в двух офисах компании, один маленький офис, второй чуть побольше. На роутере во втором офисе мы остановились на настройке статической маршрутизации, чем мы и займемся.

Таблица маршрутизации

Первое с чем нужно познакомиться, это с понятием таблицы маршрутизации. Если в двух словах это некая карта маршрутов, до сетей о которых знает ваш коммутатор 3 уровня или роутер. Для большей наглядности ее можно сравнить с картой дорог до городов России. И для того, чтобы например мне попасть из Москвы в Нижний Новгород, я должен выбрать определенную дорогу. Так и ваш роутер выбирает ее. Далее если мне нужно из Москвы попасть в Казань, и мне нужно ехать туда через Нижний Новгород, то В НН должен быть свой маршрут до Казани и так далее.

Статический маршрут — это постоянный неизменный маршрут, чаще всего прописанный в ручную.

Схема сети офисов

У нас есть филиал, в котором 3 компьютера коммутатор второго уровня Cisco 2960 и Роутер Cisco 1841, есть три vlan (2,3,4). Есть главный офис в котором есть 5 vlan (2,3,4,5), маршрутизацией локального трафика занимается ядро в виде коммутатора 3 уровня Cisco 3560, который VLAN 5 подключен к роутеру Cisco 2911, на котором настроен будет интернет и канал до филиала.

В предыдущем посте где мы создавали данную локальную сеть я не настроил vlan 5 на роутере и ядре, исправим это.

Настройка Cisco 2911 и Cisco 3560

Настройка Cisco 3560

Создаем Vlan 5
vlan 5
name VLAN5
exit

Настроим ip адрес VLAN5
int vlan 5
ip address 192.168.5.1 255.255.255.0
exit

Добавим порт gi1/1 в VLAN5
int gi0/1

выставляем режим доступа
switchport mode access
switchport access vlan 5
no shutdown
do wr mem

Настройка Cisco 2911

Так как у нас локальной маршрутизацией трафика занимается ядро то тут sub интерфейсов создавать не нужно. Настроим порт роутера gi0/0 на vlan5.

Добавление статических маршрутов на Cisco 2911

Так как наш роутер Cisco 2911 ничего не знает о сетях 192.168.1.0, 192.168.2.0, 192.168.3.0, то нужно задать ему статические маршруты до них, через ядро делается это следующим образом.

Удостоверимся что пинг не проходит до компьютера 192.168.1.1, вводим на роутере.

Видим ответов нет

Переходим в режим конфигурирования командой

и смотрим команду ip:

access-list Named access-list

cef Cisco Express Forwarding

default-gateway Specify default gateway (if not routing IP)

default-network Flags networks as candidates for default routes

dhcp Configure DHCP server and relay parameters

Читайте также:  Как настроить serato во

domain IP DNS Resolver

domain-lookup Enable IP Domain Name System hostname translation

domain-name Define the default domain name

flow-export Specify host/port to send flow statistics

forward-protocol Controls forwarding of physical and directed IP broadcasts

ftp FTP configuration commands

host Add an entry to the ip hostname table

local Specify local options

name-server Specify address of name server to use

nat NAT configuration commands

route Establish static routes

routing Enable IP routing

ssh Configure ssh options

tcp Global TCP parameters

Нам нужна команда ip route.

так как ip адрес на ядре сети (Cisco 3560) у VLAN 5 у нас 192.168.5.1 то он будет выступать для нас шлюзом. В итоге пишем.

и выполнив теперь команду Ping мы видим. что пакет дошел до 192.168.1.1

Планирование сети

Все бы хорошо, но мы не правильно спланировали сеть в удаленном офисе. Так как там как и в главном, тоже есть сеть 192.168.1.0, 192.168.2.0, 192.168.3.0, такого быть не должно иначе получается дубли. Как правильно планировать сеть я писал тут, вам нужно перенастроить, как ранее описано в предыдущей статье. В итоге в филиале я заменил сети на 11, 22, 33 третьи актеты ip адреса. Общая картина теперь выглядит так.

Соединение роутеров

Соединяем наши роутеры. Предположим, что между ними есть прямой линк, в жизни конечно это VPN канал. настроим в начале роутер Cisco 2911 в главном офисе.

маска тут 32 бита так как нам достаточно всего 2 ip адреса.

Теперь настроим роутер Cisco 1841 в филиале. У меня это интерфейс fa0/1

У нас загорелись порты обоих коммутаторов.

Проверяем пинги с роутеров друг до друга

Видим, что все успешно.

Настройка маршрутов между роутерами

Пробуем например с роутера в филиале пропинговать компьютер 192.168.1.1, и естественно пинг не пройдет так как нет маршрутов, чем мы и займемся. Так как у нас один шлюз соединения между офисами, то правильнее будет прописать один дефолтный путь, но можно и прописывать конкретный статический маршрут, например если основной шлюз интернет и весь трафик по умолчанию идет туда и вы хотите на конкретную сеть завернуть через другой шлюз.

но если бы нужно было прописать ручками каждый то вот так

ip route 192.168.1.0 255.255.255.0 192.168.100.1

ip route 192.168.2.0 255.255.255.0 192.168.100.1

ip route 192.168.3.0 255.255.255.0 192.168.100.1
do wr mem

Настроим теперь роутер у главного офиса, нам нужно добавить маршруты до сетей 192.168.11.0, 192.168.22.0, 192.168.33.0.

либо если нужно в ручную отдельным маршрутом.

Настройка маршрутов на ядре

Напомню, что локальный трафик маршрутизирует ядро сети коммутатор 3 уровня Cisco 3560, и на нем нужно тоже указать маршруты, до филиала. В качестве шлюза указывается, ip адрес vlan5 на роутере 2911 192.168.5.251

Вот финальный вид нашей филиальной сети.

Берем теперь компьютер из филиала с ip адресом 192.16811.1 и пробуем с него пропинговать 192.168.1.1 для примера. И видим, что все отлично пингуется, значит связь между офисами есть.

Читайте также:  Универсальный пульт для телевизора как настроить для телевизора филипс

Посмотреть таблицу маршрутизации на Cisco можно командой

Где буква C означает что соединение установлено, буква S означает что маршрут статический.

Вот так вот просто объединить офисы в одну сеть, мы с вами разобрались со статической маршрутизацией, рассмотрели ее на примерах. В организации тестового стенда мне помог симулятор, Скачать Cisco packet tracer можно тут. На этом все.

Популярные Похожие записи:

10 Responses to Статическая маршрутизация Cisco

Спасибо за статью.

Помогите разобраться с маршрутизацией и настроить доступ к локальным сетям:
Есть три здания:
Здание1 IP-адрес внешний 10.135.13.129 Маска 255.255.255.128 IP-адрес внутренний 150.150.2.3 Маска 255.255.0.0

Здание 2 IP-адрес внешний 10.135.59.1 Маска 255.255.255.128 IP-адрес внутренний 192.168.30.1 Маска 255.255.255.0

Здание 3 IP-адрес внешний 10.135.67.1 Маска 255.255.255.128 IP-адрес внутренний 192.168.0.1 Маска 255.255.255.0

Ping между роутерами Cisco по внешним адресам есть

У меня вот такое предположение:

ip route 192.168.30.0 255.255.255.0 10.135.13.129

ip route 192.168.0.0 255.255.255.0 10.135.13.129

ip route 150.150.0.0 255.255.0.0 10.135.59.1

ip route 192.168.0.0 255.255.255.0 10.135.59.1

ip route 150.150.0.0 255.255.0.0 10.135.67.1

ip route 192.168.30.0 255.255.255.0 10.135.67.1

Ping к компьютерам из внутренних сетей не проходит.

а по трассировкам куда трафик идет?

Трассировка до яндекса

Трассировка маршрута к YA.ru [213.180.193.3]
с максимальным числом прыжков 30:

Хотя по логике должно быть так:

Route -p add 192.168.30.0 mask 255.255.255.0 10.135.59.1

Route -p add 192.168.0.0 mask 255.255.255.0 10.135.67.1

Route -p add 150.150.0.0 mask 255.255.0.0 10.135.13.129

Route -p add 192.168.0.0 mask 255.255.255.0 10.135.67.1

Route -p add 150.150.0.0 mask 255.255.0.0 10.135.13.129

Route -p add 192.168.30.0 mask 255.255.255.0 10.135.59.1

Нашел ошибку(мешали остатки настроек от прошлого хозяина) теперь трессеровка вот так выглядит:

Трассировка маршрута к 192.168.30.1 с максимальным числом прыжков 30

Алексей извините, что не ответил, отсутствовал по уважительной причине, сын родился 🙂 Рад, что вы нашли у себя причину проблемы.

Про маршрутизацию всё рассказали и показали, а вот доступ к Интернету, что-то упустили,хотелось бы по подробнее, или я что-то не увидел? =)

…маска тут 32 бита так как нам достаточно всего 2 ip адреса
ip address 192.168.100.1 255.255.255.252

имелось в виду маска 30 бит, а не 32?

Спасибо, за статью.
Однако, если прописывать в ручную
на Router0 (1841):
ip route 192.168.1.0 255.255.255.0 192.168.100.1
ip route 192.168.2.0 255.255.255.0 192.168.100.1
ip route 192.168.3.0 255.255.255.0 192.168.100.1
на Router1 (2911):
ip route 192.168.11.0 255.255.255.0 192.168.100.2
ip route 192.168.22.0 255.255.255.0 192.168.100.2
ip route 192.168.33.0 255.255.255.0 192.168.100.2
то пинги между сетями не проходят. Маршрутизатор 2911 не пропускает из сети 192.168.100.0 в 192.168.5.0 и наоборот.
А вот если прописать
на Router0 (1841):
ip route 0.0.0.0 0.0.0.0 192.168.100.1
на Router1 (2911):
ip route 0.0.0.0 0.0.0.0 192.168.100.2
то всё норм.

Источник

Adblock
detector