Меню

Mac telnet mikrotik не работает

Гайд по Mikrotik RoMON

У всех бывали ситуации, когда необходимо настроить удаленное оборудование(иногда новое), а доступ имеется только к другим сетевым девайсам, никаких ПК/Ноутбуков и пользователей с телефонами. В случае с Mikrotik эту проблему можно решить двумя путями: встроенный в RouterOS mac-telnet и RoMON. О них и пойдет речь ниже.

Mac Telnet с роутера

Для тех кто забыл: Mac telnet работает на Layer2, поэтому подключение возможно в пределах одного сегмента сети.

Подключаемся по winbox или ssh к настроенному роутеру(Mkt1) и через него по mac-telnet к новому(Mkt2).

Где найти mac-telnet:

  • [IP]->[Neighbors] — если включено обнаружение соседей
    * [IP]->[ARP] — если на новом роутере есть какой-то ip и он резолвится в mac
    * [Tools]->[Telnet] — тут помимо mac-telnet есть обычный telnet и ssh
    * /tool mac-telnet — из консоли

Что стоит помнить: если на устройстве присутствует дефолтная конфигураци, то mac-telnet будет доступен только на lan портах(все кроме ether1, обычно), так что явно говорите монтажникам куда подключать кабель, иначе никакой mac-telnet и RoMON вам не поможет.

Доступ есть, можно настраивать, но ведь хочется удобства? Особенно при настройке деревьев очередей и большого числа правил фаервола.

Подключение через RoMON

RoMON(Router Management Overlay Network) — Возможность использовать одно устройство mikrotik к которому есть доступ по ip в качестве транзита для подключения к устройству по mac.

RoMON отключен по умолчанию. Клиентская часть встроена в winbox, так что ничего доустанавливать не потребуется.

Настройка на транзитном роутере (Mkt1):

  • Enabled — Включение RoMON
    * ID — Ручная установка RoMON ID, по умолчанию выбирается один из mac адресов роутера
    * Secrets — Набор паролей для аутентификации по RoMON, используются, если явно не указан пароль на порту. На wiki подробна расписана процедура выбора пароля.

По дефолту включены ВСЕ порты, что не особо безопасно и отключить all не представляется возможным, так что устанавливаем у него Forbid=yes, более точные правила для интерфейсов перекроют all.

Создаем правило для ether4:

  • Interface — порт для которого производим натсройки
    * Forbid — запретить работу RoMON на интерфейсе
    * Cost — учитывается при построении пути в больших герляндах
    * Secrets — Набор паролей для аутентификации

Источник

Mac telnet mikrotik не работает

У всех бывали ситуации, когда необходимо настроить удаленное оборудование(иногда новое), а доступ имеется только к другим сетевым девайсам, никаких ПК/Ноутбуков и пользователей с телефонами. В случае с Mikrotik эту проблему можно решить двумя путями: встроенный в RouterOS mac-telnet и RoMON. О них и пойдет речь ниже.

Mac Telnet с роутера

Читайте также:  Как настроить карбюратор мотороллер муравей

Для тех кто забыл: Mac telnet работает на Layer2, поэтому подключение возможно в пределах одного сегмента сети.

Подключаемся по winbox или ssh к настроенному роутеру(Mkt1) и через него по mac-telnet к новому(Mkt2).

Где найти mac-telnet:

* [IP]->[Neighbors] — если включено обнаружение соседей
* [IP]->[ARP] — если на новом роутере есть какой-то ip и он резолвится в mac
* [Tools]->[Telnet] — тут помимо mac-telnet есть обычный telnet и ssh
* /tool mac-telnet — из консоли

Что стоит помнить: если на устройстве присутствует дефолтная конфигураци, то mac-telnet будет доступен только на lan портах(все кроме ether1, обычно), так что явно говорите монтажникам куда подключать кабель, иначе никакой mac-telnet и RoMON вам не поможет.

Доступ есть, можно настраивать, но ведь хочется удобства? Особенно при настройке деревьев очередей и большого числа правил фаервола.

Подключение через RoMON

RoMON(Router Management Overlay Network) — Возможность использовать одно устройство mikrotik к которому есть доступ по ip в качестве транзита для подключения к устройству по mac.

RoMON отключен по умолчанию. Клиентская часть встроена в winbox, так что ничего доустанавливать не потребуется.

Настройка на транзитном роутере (Mkt1):

[Tools]->[RoMON]

* Enabled — Включение RoMON
* ID — Ручная установка RoMON ID, по умолчанию выбирается один из mac адресов роутера
* Secrets — Набор паролей для аутентификации по RoMON, используются, если явно не указан пароль на порту. На wiki подробна расписана процедура выбора пароля.

[Tools]->[RoMON]->[Ports]

По дефолту включены ВСЕ порты, что не особо безопасно и отключить all не представляется возможным, так что устанавливаем у него Forbid=yes, более точные правила для интерфейсов перекроют all.

Создаем правило для ether4:

* Interface — порт для которого производим натсройки
* Forbid — запретить работу RoMON на интерфейсе
* Cost — учитывается при построении пути в больших герляндах
* Secrets — Набор паролей для аутентификации

/tool romon port

set [ find default=yes ] forbid=yes

add disabled=no interface=ether4 secrets=test-for-romon

Настройка на удаленном роутере (Mkt2):
Тут у нас подключение по mac-telnet, так что и настройки будут консольными:

/tool romon port

set [ find default=yes ] forbid=yes

add disabled=no interface=ether5 secrets=test-for-romon


Теперь в [Tools]->[RoMON]->[Discovery] на Mkt1 мы видим соседа:

И еще одного соседа, который подключен транзитом через Mkt2, оставляю настройку этого соединения в качестве самостоятельного задания, все аналогично.

Подключение

Запускаем Winbox и коннектимся к 2.2.2.2 в режиме RoMON используя обычную учетную запись и пароль, secrets в RoMON относится только к связи между роутерами:

И тут мы видим самое интересное — все роутеры в «герлянде» RoMON доступны для подключения через единственный транзитный Mikrotik.

Выбираем один из адресов(RoMON ID) и подключаемся к интересующему роутеру.

Итог: Получаем прозрачный доступ до всех роутеров в цепочке, без необходимости последовательного логина через mac-telnet.

Дополнительно

[Tools]->[RoMON]->[Ping] — утилита для пинга роутеров по RoMON ID.

Обычный mac-telnet не является безопасным каналом связи, при наличии RoMON можно устанавливать ssh подключение по RoMON ID.

Подключение через RoMON в режиме коммандной строки(для ярлыков):

На этом все. Функционал не для повседневного использования, но полезно о нем помнить и знать как настроить.

Источник

Mac telnet mikrotik не работает

November 18, 2016

If you know Mikrotik Routers you know that you’re able to access them via MAC Telnet (see here for more details) via Layer2 with Winbox. But running Winbox via Wine on a Linux is not that great for using MAC Telnet, and there is a better way .. just use MAC-Telnet from Håkon Nessjøen. On Ubuntu/Debian you can just install the package with

sudo apt-get install mactelnet-client

and you see its feature like this:

$ mactelnet -h
MAC-Telnet 0.4.2
Usage: mactelnet [-h] [-n] [-a

Parameters:
MAC MAC-Address of the RouterOS/mactelnetd device. Use mndp to
discover it.
identity The identity/name of your destination device. Uses
MNDP protocol to find it.
-l List/Search for routers nearby (MNDP). You may use -t to set timeout.
-B Batch mode. Use computer readable output (CSV), for use with -l.
-n Do not use broadcast packets. Less insecure but requires
root privileges.
-a

Use specified path instead of the default:

/.mactelnet for autologin config file.
-A Disable autologin feature.
-t Amount of seconds to wait for a response on each interface.
-u Specify username on command line.
-p

Specify password on command line.
-U Drop privileges to this user. Used in conjunction with -n
for security.
-q Quiet mode.
-h This help.

So lets give it a try, first with searching for my home router

$ mactelnet -l
Searching for MikroTik routers. Abort with CTRL+C.
IP MAC-Address Identity (platform version hardware) uptime
10.x.x.x 0:xx:xx:xx:xx:xx jumpgate (MikroTik x.x.x. xxxx) up 139 days 5 hours XXXXX-XXXX vlanInternal

and then we’ll connect

and we’re connected.

1 Comment »

You can also just type; mactelnet jumpgate instead of copying the mac address.

Comment by Håkon — November 19, 2016 #

Leave a comment

Powered by WordPress
Entries and comments feeds. Valid XHTML and CSS. 49 queries. 0.076 seconds.

Источник

Инструкции по настройке MikroTik

Настройка утилиты RoMON на роутере MikroTik, удаленное управление через Winbox

Одной из приятных функций Winbox является автообнаружение устройств по MAC адресу. Это абсолютно полезная опция становится частым решением в настройке оборудования MikroTik.

Утилита RoMON(Router Management Overlay Network) предоставляет доступ к функции автообнаружения через уникальные идентификаторы RoMON ID. Из-за того, что данный тип соединение ни как не шифруется, принято использовать только на LAN интерфейсах.

Как работает RoMON в MikroTik

Частой задачей при настройки больших сетей являет доступ не только к центральному маршрутизатору(роутеру) MikroTik, но также и к коммутатору или точке доступа WiFi. Как подобные задачи решаются без RoMON?

К каждому устройству нужно пробрасывать внешний порт или создавать VPN подключение и уже с локальной сети пытаться подключиться к нужному устройству. Ситуации бывают разные и иногда RoMON становится единственным доступным решением.

Ссылки на смежные статьи:

Если у вас не работает RoMON – просмотрите наглядную инструкцию по активации и подключению к устройствам MikroTik на реальном примере.

Пример настройки RoMON на MikroTik hAP ac2 и MikroTik cAP ac

Имеется стандартная сеть на устройствах MikroTik, состоящая из маршрутизатора(роутера) и внутренних WiFi точках. Список действий будет состоять из пунктов:

  1. Подключение к роутеру MikroTik по внешнему IP адресу;
  2. Активация RoMON на центральном роутере MikroTik;
  3. Просмотр локальных устройств через закладку Neighbors;
  4. Подключение к устройству через MAC Telnet;
  5. Активация на устройстве утилиты RoMON;
  6. Переподключение к роутеру MikroTik кнопкой “Connect to RoMON”;
  7. Обновление списка устройств в закладке Neighbors;
  8. Повторить п. 1-6 для каждого устройства.

Подключение к роутеру MikroTik по внешнему IP адресу

Активация RoMON на центральном роутере MikroTik

Настройка находится в System→RoMON

Просмотр локальных устройств через закладку Neighbors, подключение к устройству через MAC Telnet

Настройка находится в IP→Neighbors

Поддержи автора статьи, сделай клик по рекламе ↓↓↓

Активация на устройстве утилиты RoMON

Переподключение к роутеру MikroTik кнопкой “Connect to RoMON”

Обновление списка устройств в закладке Neighbors

Есть вопросы или предложения по настройке RoMON в MikroTik? Активно предлагай свой вариант настройки! Оставить комментарий

adminse

Один комментарий к статье “Настройка утилиты RoMON на роутере MikroTik, удаленное управление через Winbox”

У меня эта схема не заработала. Видимо в статье ошибка? Речь ведь не идет о работающем CAPsMAN?

“Имеется стандартная сеть на устройствах MikroTik, состоящая из маршрутизатора(роутера) и внутренних WiFi точках.”

При работающем капсмане все ОК, а при простом подключении AP к роутеру (настроеных как Home AP) – нет

Источник

Adblock
detector