Меню

Mikrotik не работает dns по vpn

Mikrotik не работает dns по vpn

Бесплатный чек-лист
по настройке RouterOS
на 28 пунктов

DNS запросы через VPN

Правила форума
Как правильно оформить вопрос.
Прежде чем начать настройку роутера, представьте, как это работает. Попробуйте почитать статьи об устройстве интернет-сетей. Убедитесь, что всё, что Вы задумали выполнимо вообще и на данном оборудовании в частности.
Не нужно изначально строить Наполеоновских планов. Попробуйте настроить простейшую конфигурацию, а усложнения добавлять в случае успеха постепенно.
Пожалуйста, не игнорируйте правила русского языка. Отсутствие знаков препинания и неграмотность автора топика для многих гуру достаточный повод проигнорировать топик вообще.

1. Назовите технологию подключения (динамический DHCP, L2TP, PPTP или что-то иное)
2. Изучите темку «Действия до настройки роутера».
viewtopic.php?f=15&t=2083
3. Настройте согласно выбранного Вами мануала
4. Дочитайте мануал до конца и без пропусков, в 70% случаев люди просто не до конца читают статью и пропускают важные моменты.
5. Если не получается, в Winbox открываем терминал и вбиваем там /export hide-sensitive. Результат в топик под кат, интимные подробности типа личных IP изменить на другие, пароль забить звездочками.
6. Нарисуйте Вашу сеть, рисунок (схему) сюда. На словах может быть одно, в действительности другое.

Приветствую, с микротиками только познакомился, пока глаза разбегаются в настройках.
Замучал меня провайдер подменяя DNS запросы, блокировка ресурсов не так страшна, больше раздражает подпихивание время от временеи рекламы и акций всяких, типа «иптв заполцены!». Ну суть не в этом, захотелось мне DNS обезопасить, чтоб и на персональных и на мобильных и др.устройствах работало без настройки. Вначале подумал про DNSCrypt, но не поддержиает его микротик, поэтому решил заворачивать DNS запросы в vpn (весь трафик заворачивать не нужно). Пока намереваюсь сделать так — поднять впн соединение (SSTP, PPTP или L2TP), не заворачивая на него весь трафик, перехватывать весь трафик на 53 порту и отправлять его на микротик, а микротику в DNS указать локальный удаленный ип впн сервера (на котором dnsmasq к примеру), ну или сразу трафик заворачивать на удаленный локальный ип впн сервера.

Подскажите, может быть это уже предусмотрено и есть другие неочевидные для меня варинаты настройки, так же буду рад примерам, чтобы полегче настраивать было.

Приветствую, с микротиками только познакомился, пока глаза разбегаются в настройках.
Замучал меня провайдер подменяя DNS запросы, блокировка ресурсов не так страшна, больше раздражает подпихивание время от временеи рекламы и акций всяких, типа «иптв заполцены!». Ну суть не в этом, захотелось мне DNS обезопасить, чтоб и на персональных и на мобильных и др.устройствах работало без настройки. Вначале подумал про DNSCrypt, но не поддержиает его микротик, поэтому решил заворачивать DNS запросы в vpn (весь трафик заворачивать не нужно). Пока намереваюсь сделать так — поднять впн соединение (SSTP, PPTP или L2TP), не заворачивая на него весь трафик, перехватывать весь трафик на 53 порту и отправлять его на микротик, а микротику в DNS указать локальный удаленный ип впн сервера (на котором dnsmasq к примеру), ну или сразу трафик заворачивать на удаленный локальный ип впн сервера.

Читайте также:  J120 samsung не работает микрофон

Подскажите, может быть это уже предусмотрено и есть другие неочевидные для меня варинаты настройки, так же буду рад примерам, чтобы полегче настраивать было.

Так зачем отлавливать? Вы эезнаете какие днс выдаете на машины.
Маршруты до этих серверов пропишите через впн и все дела

А провайдеру можно написать претензию. Их обязывают доступ закрывать. ДНС это не доступ, по крайней мере у меня прокатило — перестали перехватывать

Источник

Mikrotik не работает dns по vpn

Бесплатный чек-лист
по настройке RouterOS
на 28 пунктов

DNS: VPN L2TP + ipsec, клиенты VPN не видят ПК по сетевому имени

Правила форума
Как правильно оформить вопрос.
Прежде чем начать настройку роутера, представьте, как это работает. Попробуйте почитать статьи об устройстве интернет-сетей. Убедитесь, что всё, что Вы задумали выполнимо вообще и на данном оборудовании в частности.
Не нужно изначально строить Наполеоновских планов. Попробуйте настроить простейшую конфигурацию, а усложнения добавлять в случае успеха постепенно.
Пожалуйста, не игнорируйте правила русского языка. Отсутствие знаков препинания и неграмотность автора топика для многих гуру достаточный повод проигнорировать топик вообще.

1. Назовите технологию подключения (динамический DHCP, L2TP, PPTP или что-то иное)
2. Изучите темку «Действия до настройки роутера».
viewtopic.php?f=15&t=2083
3. Настройте согласно выбранного Вами мануала
4. Дочитайте мануал до конца и без пропусков, в 70% случаев люди просто не до конца читают статью и пропускают важные моменты.
5. Если не получается, в Winbox открываем терминал и вбиваем там /export hide-sensitive. Результат в топик под кат, интимные подробности типа личных IP изменить на другие, пароль забить звездочками.
6. Нарисуйте Вашу сеть, рисунок (схему) сюда. На словах может быть одно, в действительности другое.

Добрый день,
Думаю, что решение проблемы простое, но не нашел описание на форуме.
Mikrotik поднят VPN: L2TP + Ipsec
Локальная сеть: 192.168.0.0/24
IP: NAS-synology 192.168.0.45
IP: Mikrotik 192.168.0.1
IP: client VPN 192.168.11.198
Client VPN не видит по сетевому имени NAS. По IP адресу пингует, nslookup 192.168.0.45 возвращает имя. Не пингует NAS-synology.
На DNS Mikrotik в Statik прописан 192.168.0.45 NAS-synology

Адаптер PPP VPNL2:

DNS-суффикс подключения . . . . . :
Описание. . . . . . . . . . . . . : VPNL2
Физический адрес. . . . . . . . . :
DHCP включен. . . . . . . . . . . : Нет
Автонастройка включена. . . . . . : Да
IPv4-адрес. . . . . . . . . . . . : 192.168.11.198(Основной)
Маска подсети . . . . . . . . . . : 255.255.255.255
Основной шлюз. . . . . . . . . : 0.0.0.0
DNS-серверы. . . . . . . . . . . : 192.168.0.1
NetBios через TCP/IP. . . . . . . . : Включен

Адаптер беспроводной локальной сети Беспроводная сеть:

DNS-суффикс подключения . . . . . :
Описание. . . . . . . . . . . . . : Dell Wireless 1810 802.11ac
Физический адрес. . . . . . . . . : D8-0F-99-6D-8A-05
DHCP включен. . . . . . . . . . . : Да
Автонастройка включена. . . . . . : Да
Локальный IPv6-адрес канала . . . : fe80::9494:1700:7db2:9e45%11(Основной)
IPv4-адрес. . . . . . . . . . . . : 192.168.43.174(Основной)
Маска подсети . . . . . . . . . . : 255.255.255.0
Аренда получена. . . . . . . . . . : 28 февраля 2020 г. 10:12:10
Срок аренды истекает. . . . . . . . . . : 28 февраля 2020 г. 11:15:30
Основной шлюз. . . . . . . . . : 192.168.43.1
DHCP-сервер. . . . . . . . . . . : 192.168.43.1
IAID DHCPv6 . . . . . . . . . . . : 114823065
DUID клиента DHCPv6 . . . . . . . : 00-01-00-01-20-C0-C3-EF-50-9A-4C-B3-C0-BA
DNS-серверы. . . . . . . . . . . : 192.168.43.1
NetBios через TCP/IP. . . . . . . . : Включен

Источник

DNS VPN Miktrotik?

Есть 2 офиса, у меня там стоят микротики соединенные по pptp
Хосты в подсети 1 не пингуются по имени хоста из подсети 2 и также в обратную сторону (по ip пинг есть)
В DNS на 1-м микротике указан ip 2-го, и наоборот, но так не работает..

Как правильно пробросить DNS?

  • Вопрос задан более двух лет назад
  • 296 просмотров

В DNS на 1-м микротике указан ip 2-го, и наоборот

Рональд Макдональд, А, я подумал с подвохом вопрос)

Читайте также:  Почему не работает башинформсвязь

Да, они и АД сервер, на котором только он сам. Он кстати тоже указан в качестве ДНС, но виден только в той сети, в которой находится.

2 Сети — это 114.0 и 0.0

set allow-remote-requests=yes servers=\
91.***.***.**,91.***.***.**,192.168.114.100,192.168.0.1

Тут указаны провайдерские днсы, 114.100 — это АД, 0.1 — это второй микротик

Нет, у каждого свой, они должны работать абсолютно независимо

Рональд Макдональд, Сегодня максимально туплю, сори 😉

/ip pool
add name=dhcp ranges=192.168.114.5-192.168.114.255
add name=pool1 ranges=192.168.252.40-192.168.252.254
add name=pool_free_wifi ranges=10.1.1.2-10.1.1.50
/ip dhcp-server
add add-arp=yes address-pool=dhcp authoritative=after-2sec-delay disabled=no \
interface=LAN-Bridge lease-time=1d name=server1
add add-arp=yes address-pool=pool_free_wifi authoritative=after-2sec-delay \
disabled=no interface=bridge_Free_wifi name=server_free_wifi

Мои настройки в аналогичной ситуации:

«. » выделил DNS-сервер на другом конце VPN и добавил в список DNS сам удалённый Микротик.

Источник

Условная переадресация DNS-запросов на MikroTik

Научиться настройке MikroTik можно на онлайн курсе по оборудованию этого производителя. Автор курса является сертифицированным тренером MikroTik. Подробней Вы можете прочитать в конце статьи.

Вводная информация DNS forwarding

Если используете маршрутизатор MikroTik с настроенным VPN между офисами, вероятно приходилось сталкиваться с проблемой переадресации DNS-запросов на внутренний сервер имён. Существует DNS-сервер, который автоматически разрешает имена сайтов на другом конце туннеля. Однако, если вы запрашиваете DNS-запись для внутреннего домена, например, company.ru, на другом конце, маршрутизатор MikroTik попытается преобразовать запрос через собственный DNS-сервер, который, очевидно, не имеет необходимой информации. Разберемся с проблемой DNS forwarding более детально.

У вас всегда есть возможность создавать записи вручную в файле хостов или добавлять ручные записи на ваш DNS-сервер, однако, если количество сайтов является значительным, это может превратиться в настоящую проблему, не говоря уже о том, что ваши записи не будут обновляться в случае изменения записей DNS на корпоративном сервере.

Как ни странно, у Микротика нет простого решения для условной пересылки DNS или пересылки DNS-запросов для определенного домена на конкретный сервер, однако мы сможем решить данную задачу с помощью командной строки.

Буду считать, что читатель знаком с командной строкой Mikrotik и нет необходимости расписывать используемый функционал, – это выходит за рамки этой публикации. В решении мы будем работать на 7 уровне сетевой модели OSI или прикладном уровне.

Прежде чем начать, вам понадобится следующая информация:

  • Внутренний IP адрес вашего маршрутизатора MikroTik (172.16.100.1 в моем случае)
  • IP адрес внутреннего DNS сервера (10.100.100.2 в моем случае)
  • Имя внутреннего домена (mycompany.ru в моем случае)
  • Доступ к маршрутизатору Микротик по протоколу ssh

Приступим к решению

1. Откройте текстовый редактор, например, notepad и вставьте следующие команды:

2. В списке команд выше необходимо изменить внутренний IP-адрес вашего маршрутизатора (зеленый цвет), имя внутреннего домена (оранжевый цвет) и адрес внутреннего DNS сервера (синий цвет) в соответствии с вашими настройками в текстовом редакторе.

3. Откройте ssh-сеанс на маршрутизаторе MikroTik и вставьте отредактированное содержимое текстового редактора в командную строку.

4. Перезагрузите маршрутизатор, чтобы изменения вступили в силу

Поиск неисправностей

Нам необходимо проверить, сможем ли попасть на сайты интрасети с другой стороны VPN. Если вы не можете, убедитесь, что туннель vpn запущен и работает, и что сайты действительно доступны через их внутренние IP-адреса, например, проверка по ping-протоколу нашего DNS-сервера 10.100.100.2. Следующим шагом является устранение проблемы с разрешением DNS при помощи таких команд, как nslookup. Сначала убедитесь, что DNS-сервер с другой стороны туннеля отвечает на запросы NS, выдавая команду:

Читайте также:  Беременная 6 месяцев не могу работать

где 10.100.100.2 DNS-сервер Интранета.

После приглашения > введите имя одного из ваших сайтов интрасети, и сервер имен должен сообщить его IP-адрес:

Если проверка проходит, то это означает, что туннель и DNS-сервер работают как нужно. Проверим перенаправление запросов через наш маршрутизатор, для этого выполним команду на клиентском устройстве:

где 172.16.100.1 – внутренний IP-адрес нашего маршрутизатора MikroTik.

Если результат не совпадает с вышеописанным, необходимо вернутся к списку команд в текстовом редакторе и убедитесь, что всё введено правильно. Исправьте ошибки и попробуйте еще раз.

MikroTik: куда нажать, чтобы заработало?
При всех своих достоинствах, есть у продукции компании MikroTik один минус – много разобщенной и далеко не всегда достоверной информации о ее настройке. Рекомендуем проверенный источник на русском языке, где все собрано, логично и структурировано – видеокурс « Настройка оборудования MikroTik ». В курс входит 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект. Все материалы остаются у вас бессрочно. Начало курса можно посмотреть бесплатно, оставив заявку на странице курса. Автор курса является сертифицированным тренером MikroTik.

Источник

Mikrotik не работает dns по vpn

Бесплатный чек-лист
по настройке RouterOS
на 28 пунктов

DNS и VPN-клиент

Подключаюсь к микротику через VPN. Использую PPTP-сервер на микротике.
DNS указываю за микротиком.
В итоге, по IP я локалку за микротиком пингую, а по имени только по FQDN.
Вопрос, где надо дописывать DNS-суффикс, чтобы можно было пинговать просто по имени?

Сама постановка вопроса забавляет. Это типа: Поискав в гугле на тему приготовления блинчиков на микротик, набрел на обсуждение, где примерно с 2010 года поднимают этот вопрос. И, как я понимаю, воз и ныне там 🙂
Вопрос не решается, видимо потому, что или слишком простой и легко решается чтением wiki, или вообще не относится к функционалу маршрутизатора.

Микротик, как и любой другой vpn сервер без специализированного клиента, при подключении выдает только ip и шлюз.
Если в качестве DHCP сервер используется микротик, то у него есть параметр Domain.Далее читайте про DNS & DHCP клиента на используемой вами ОС.

Сама постановка вопроса забавляет. Это типа: Поискав в гугле на тему приготовления блинчиков на микротик, набрел на обсуждение, где примерно с 2010 года поднимают этот вопрос. И, как я понимаю, воз и ныне там 🙂
Вопрос не решается, видимо потому, что или слишком простой и легко решается чтением wiki, или вообще не относится к функционалу маршрутизатора.

Микротик, как и любой другой vpn сервер без специализированного клиента, при подключении выдает только ip и шлюз.
Если в качестве DHCP сервер используется микротик, то у него есть параметр Domain.Далее читайте про DNS & DHCP клиента на используемой вами ОС.

Источник

Adblock
detector