Меню

Mikrotik не работает ip телефония

Настройка Mikrotik RouterOS (SIP через NAT)

Часто пользователи IP телефонии сталкиваются с проблемой односторонней слышимости. Проблема в том, что в SIP протоколе, в части где описываются возможности голосового соединения (кодеки, IP адреса и порты обмена) — в протоколе SDP (Session Description Protocol), имеется запись о IP адресе на котором клиент ожидает соединения, и этот IP адрес, естественно является «серым», то есть из сети, которая находится за NAT-ом. А прямое соединение на этот немаршрутизируемый IP естественно невозможно. Однако, все современные IP шлюзы, понимают, что такая ситуация может возникнуть и разруливают её соответствующим образом — то есть они не обращают внимание на этот адрес, а пакеты шлют на тот адрес с которого приходят к нему пакеты, то есть на наш реальный IP, находящийся на выходе из NAT.

SIP телефоны (софтфоны) вполне корректно работают из под NAT, и порты никакие пробрасывать не надо.

В процессе изучения Mikrotik и анализа проходящего VoIP трафика, выяснилось, что роутер по умолчанию лезет в SIP/SDP протокол и подменяет установленный там IP на свой внешний (так называемый SIP ALG). Таким образом, со стороны это выглядит так, как будто и нет никакого NAT-а. И всё в порядке, и всё в общем то работает. Однако если у вас проблема с односторонней слышимостью, то вам необходимо отключить SIP ALG на роутере. Делается это следующей командой в консоли RouterOS

/ip firewall service-port disable sip

Еще одна часто возникающая проблема с роутерами Mikrotik — это зависшие UDP соединения. По наблюдениям это происходит в результате цепочки событий

1. Происходит отключение Интернет соединения
2. Устройство, находящееся за NAT, отправляет запрос в сторону SIP сервера
3. Создается ошибочная запись в таблице conntrack
4. Интернет соединение восстанавливается
5. Таблица NAT netfilter не может получить корректную информацию для новых запросов

В результате SIP-устройства не могут зарегистрироваться, хотя запросы отправляются (клиенты Ростелеком с подключением по технологии PON страдают в первую очередь, т.к. раз в сутки биллинг провайдера принудительно разрывает сессию) .

TCPDUMP в данной ситуации показывает, что UAC отправляет в сторону сервера REGISTER, сервер отвечает запросом авторизации (SIP/2.0 401 Unauthorized), а в ответ ничего не приходит. Лечится это либо перезагрузкой роутера или удалением UDP соединений из консоли Mikrotik

/ip firewall connection remove [find where protocol=udp and dst-address

/ip firewall connection remove [find where connection-type=sip and assured=no]

Если нет возможности перезагрузить роутер или удалить UDP сессии, то можно попробовать выключить SIP устройство на 15-20 минут и потом включить снова.

Если проблема не постоянная, а то появляется, то исчезает, то возможно поможет отключение технологии fastpath (необходимо перезагрузить роутер после выполнения этих команд)

/ip settings set allow-fast-path=no

/ip firewall filter disable [/ip firewall filter find where action=fasttrack-connection]

В новых версиях RouterOS появился параметр sip-timeout, который теоретически может помочь в решении данной проблемы. Попробуйте выполнить следующую команду

/ip firewall service-port set sip disabled=no ports=5060,5061 sip-direct-media=yes sip-timeout=5m

Источник

Не работает IP-телефон c микротиком

Всем привет! Столкнулся с такой проблемой:
Вчера установил микротиковский роутер RB951Ui-2HnD с версией прошивки 6.43.13.

Настроил его в quickset по предустановке Home AP и вся офисная сеть поднялась, появился интернет. В общем, все работает: у пк есть лан и вайфай, все принтеры печатают, но почему-то телефон работать не хочет.
Точнее, он получает данные в сети, но линия не работает. Я позвонил поставщику услуг телефонии, мне сказали, что не поступает регистрация и нужно «разрешить UDP трафик».

В настройках нат у меня есть masqurade. Я настраивал по гайдам, потому сильно не знаю для чего он, но может быть дело в нем? Можете подсказать, как выпустить данные телефона на волю, к провайдеру?)

Добавлено через 1 час 18 минут
Проблему решил, благодаря этому:

/ip firewall filter add chain=forward dst-add= protocol=udp dst-port=5060,10000-20000 action=accept

/ip firewall nat add chain=dstnat in-interface= protocol=udp dst-port=5060 action=netmap to-address= to-port=5060

/ip firewall service set sip disabled=no

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Не могу достучаться в сеть за микротиком
Приветствую, форумчане. Задачка для первоклашек, но, видимо, я до них не дотягиваю (( Есть.

Управление Микротиком с радиобрелка через Arduino
Добрый день! Есть задача отключения ipsec канала на Mirotik с помощью радиобрелка. Для решения.

Xamarin, приложение устанавливается на телефон, но не работает, хотя работает на эмуляторе
Приложения не запускаются на телефоне, хотя в эмуляторе работают нормально. а манифесте по версиям.

После прошивки не работает телефон
Прошивал LG E612 полностью по инструкции на 4PDA. В итоге после прошивки высвечивается логотип LG.

Источник

Mikrotik не работает ip телефония

Бесплатный чек-лист
по настройке RouterOS
на 28 пунктов

Настройка микротик интернет и sip телефония

Вот как давать совет, если я не знаю куда и как приходит провайдер.

1-й вариант: (классика, провайдер поставил свитч, на выходи Ethernet)
a) подключаете провод со свитча провайдера в порт1
б) подключаете АТС в порт2
в) сами подключаетесь в порт3
г) заходите в роутер (через утилиту WinBox)
д) создаёте бридж: bridge0-WAN
e) в этот бридж добавляете порт1 и порт2
ж) создаёте профиль (рррое-out1), вводите данные и (внимание) в настройках рррое подключения,
выбрать интерфейс: bridge0-WAN
Вроде как бы и все:
между портом 1 и 2 сделали хаб, и трафик от провайдера сразу идёт на АТС+
на этом «хабе» мы поднимаем рррое-сессию и работаем как обычно.
з) делаете локальный бридж: bridge1-LAN и туда помещаете порт3, порт4 и так далее.
В эти порты подключаете уже локальные устройства или свитч с устройствами.
Задаёте этому бриджу локальному локальный адрес, например 192.168.3.1/24.
Ну и в правилах файрвола, закладка НАТ = не забыть для всей сети разрешить НАТ,
тогда будет Интернет у всех.

2-й вариант: (не классика, провайдер подключает оптику сразу в роутер)
В целом всё тоже самое, только вместо порта1 = Вы должны работать с портом
оптики, он называется обычно sfp1 и так далее.
С ним также проделываете теже операции.

Источник

Mikrotik не работает ip телефония

Бесплатный чек-лист
по настройке RouterOS
на 28 пунктов

Mikrotik, voip шлюз, нет голоса.

Правила форума
Как правильно оформить вопрос.
Прежде чем начать настройку роутера, представьте, как это работает. Попробуйте почитать статьи об устройстве интернет-сетей. Убедитесь, что всё, что Вы задумали выполнимо вообще и на данном оборудовании в частности.
Не нужно изначально строить Наполеоновских планов. Попробуйте настроить простейшую конфигурацию, а усложнения добавлять в случае успеха постепенно.
Пожалуйста, не игнорируйте правила русского языка. Отсутствие знаков препинания и неграмотность автора топика для многих гуру достаточный повод проигнорировать топик вообще.

1. Назовите технологию подключения (динамический DHCP, L2TP, PPTP или что-то иное)
2. Изучите темку «Действия до настройки роутера».
viewtopic.php?f=15&t=2083
3. Настройте согласно выбранного Вами мануала
4. Дочитайте мануал до конца и без пропусков, в 70% случаев люди просто не до конца читают статью и пропускают важные моменты.
5. Если не получается, в Winbox открываем терминал и вбиваем там /export hide-sensitive. Результат в топик под кат, интимные подробности типа личных IP изменить на другие, пароль забить звездочками.
6. Нарисуйте Вашу сеть, рисунок (схему) сюда. На словах может быть одно, в действительности другое.

Помогите решить проблему/задачу.

Есть микротик CCR1016-12G с реальным ip адресом с настроенным натом. За натом находится Voip шлюз Grandstream gxw4232. Это шлюз который из ip делает аналог.
Так вот, этот шлюз регистрируется у провайдера Манго-Телеком, регистрация проходит нормально.
Но при звонке, после 10 секунд разговора, пропадает входящий голос.
Когда же я настраиваю обычный роутер тплинк, с реальным айпишником и стандартным натом, все работает нормально без сбоев.

Перепробовал много всего, и проброс портов и отключение всех фильтров.
Микротик так же выступает в роли хотспота и на нем весит два провайдера с автоматическим переключением на резервный канал.
Шлюз grandstream находится в отдельной подсети.
Полные настройки пока выкладывать не буду.
Пока прошу дать советы, в какую сторону посмотреть, и что можно проверить в этом случае.
Спасибо.

А Вы хитёр. Ничего не покажу, но Вы помогите.
При наличии такой железки, надо быть честным
Ладно, Ваше право!

1-й совет:
отключите «хелпер» sip внутри микротика (IP-Firewall-Service Ports — sip)
Ну и попробуйте (не сразу, а минуты через 3-10).

2-й совет(на будущее):
если у Вас два канала, то надо явно чтобы voip-шлюз смотрел чётко на своего провайдера всегда,
так как не зная как у Вас всё сделано — не буду советовать явно.

других идей пока что нет.

Стандартный sip у меня отключен.
Ниже выкладываю полный конфиг.

1) первое: всё же там, где должен стоять IP реальный, надо было IP реальный оставлять, а замазать два последних октета,
а так не всегда ясно, где айпи,а где переменная, да и названия интерфейсов лично мне приятнее понимать по их натуральному
название как ether3 или ether5, а уже по комментарию смотреть что это.
(это лично моё «фи» небольшое)

Объясните смысл явно открывать для определённой сети микротик, если по умолчанию микротик итак открыт?
То есть я вообще логики не понимаю.
(ниже тоже такие правила есть, не стал все их анализировать)

Также вопрос — зачем правила аналитики ИНВАЛИДНЫХ пакетов ставить где-то в середине файрвола?
Инвалидные пакеты надо отбрасывать в самом начале, зачем их прогонять через файрвол,
чтобы потом их убить?

Пройдитесь по файрволу (Фильтрес) и посмотрите за 2-4 дня какие правила по нулям, вот те и надо проверить,
и оптимизировать.

4)
не думали об оптимизации, у Вас всё на портах сделано, если порт отключится (получит статус оффлайна)
то и серисы/службы будут не работать, такое поведение для роутера не правильно,так что возможно часть
сервисов и главное и адресацию перенести с порта(ов) на бриджи. Так вроде даже советуют.
Бридж как логическое устройство всегда будет, и даже если порт входящий в бридж будет в ауте(по каким-то причинам),
привязанный на бридж сервис (тож же DHCP) не вылетит в ошибку.

5) Рекомендую отказаться от переименования стандартных портов, всё же роутер у Вас боевой и
должно выглядеть как-то единообразно, а для удобства — использовать возможность создания листов интерфейсов,
которые можно использовать во всех цепочках файрволах. Я говорю о Interface List (находиться
в окне Interface, вторая закладка). Очень удобно один раз там описать все интерфейсы, дать им
названия, комментарии. И уже использовать почти везде. Но зато в таблице маршрутизации будет
более стандартное видение и понимание что куда.

6) пока не до конца разобрался с маркировкой, конфиг читать сложно, ибо у Вас то что описал я в пункте 1
Но пока дам совет, может телефонию маркировать не mark-routing, а всё же mark-connection, тем более
так советовали на курсах (тренер).

Источник

Через Mikrotik не проходит регистрация SIP телефонии

Приобрели Mikrotik Chateau LTE12 для использования в офисе, минуя местного проводного провайдера с конскими тарифами. Имеется так же голосовой шлюз SIP телефонии от другого провайдера. И при переходе на Mikrotik возникли сложности — не проходит регистрация SIP телефонии. Ранее с продукцией Mikrotik я дела вообще не имел. Понимаю, что нужно в настройках «Firewall» прописать какие-то правила, но ничего «разжеванного» для новичков по этому вопросу не нашел.

Направьте пожалуйста в нужное русло

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Организация SIP-телефонии
Всем привет! Надеюсь вы поможете мне вникнуть в тонкости IP телефонии. 🙂 Что есть: 30.

Обработка SIP телефонии. Возможно ли?
Всем привет, написал небольшую программульку для заказчика по учёту клиентов и рассылки смс(Delphi.

Как происходит работа sip телефонии?
всем привет. интересует вопрос если у меня установлен сип сервер и сип клиент и они настроены, .

Sip mikrotik
Добрый день! Имеется сервер ip телефонии oktell за nat микротик. Для работы телефонии необходимы.

какой порт на сервере провайдера для регистрации? 5060, 5070?
и протокол какой? UDP, TCP?

Добавлено через 7 минут
и сразу заодно:

в numbers впишите номер поля # из результата ip firewall service-port print, которому соответствует sip

покажите потом вывод этой команды и проверьте

тут микротик судя по всему не при чем

Уточнил по поводу «какой порт на сервере провайдера для регистрации? 5060, 5070?
и протокол какой? UDP, TCP?»

Порт стандартный 5060
Протокол UDP

Добавлено через 1 минуту
Подключение к интернету через сотовый канал (Yota)

микротик его не блочит в направлении интернета.

Перекидываем провод от шлюза в роутер от старого провайдера (проводного), шлюз сразу цепляется. пакеты передаются.

Добавлено через 1 минуту
Поддержка телефонии говорит, что есть клиенты на Yota. Проблем нет.

Через местного да, идет. Причем с техподдержкой IP телефонии попробовали передать пакет через компьютер, подключенный по локалке к Микротику. Использовали программу Zoiper. Пакет данных передался на провайдера, а с их голосового шлюза не передается почему-то.

Добавлено через 4 минуты
Даунгрейдить пока не стал. Жду обратной связи от техподдержки провайдера IP телефонии. Что-то пробуют в шлюзе своем настроить. Сейчас как свяжемся, протестим. Если опять не выйдет, даунгрейд сделаю.

Добавлено через 43 минуты
В общем техподдержка Ip телефонии предполагает, что нужно прописывать правило в NAT для этого голосового шлюза. Как это сделать? Подскажите пожалуйста.

о да, так и вижу, нат местного провайдера их не смутил, а нат йоты такой сякой, нужно какое-то правило, вообще всяким провайдерам тяжело чего-то доказать

добавляйте в самый верх лог правила срц=213.167.57.х, и второе дст=213.167.57.х, цепочка forward и переазгрузите голосовой шлюз, что будет в логах покажите

в процессе регистрации нат никаким боком влиять не может, это потом при звонке, может быть односторонняя слышимость, при неверных настройках

sip — регистрация на провайдере
Добрый день. Стоит 2800. На ней оконечиваются SIP-аккаунты. Задача — добавить ещё один аккаунт.

Asterisk регистрация sip
Два, возможно — тесно связанных вопроса: 1) В sip.conf есть 2 примера, как можно подключиться к.

Почему при указании пути через имя компа сканирование не проходит, а через IP — проходит?
Всем доброго времени суток, Ситуация такая — Есть 3 компа с Windows 7 на борту (у всех их.

SIP-регистрация и получение ответного XML
Привет всем! Подскажите, пожалуйста, бесплатную .NET-библиотеку для работы с SIP, которая после.

Регистрация не проходит в БД
Регистрация не проходит, зарегистрированные данные(login,password и т.д.) не сохраняются в базе. В.

Проходит регистрация но не регистрирует в Джумле 3
Доброго времени суток! На сайте Joomla 3 Virtue mart 3 и отключенная капча. После заполнения всех.

Источник

Читайте также:  Gi 2628 настроить шаринг
Adblock
detector